SYMPTOMS
Users receive this error when navigating to a workflow queue in Synergize Web Explorer
CAUSE
Invalid character types were entered for a document field during indexing
RESOLUTION
1. Log into Microsoft SQL Server Management Studio and navigate to the database with same name as the repository with the Workflow.
2. Query the Main table using the SELECT statement below to identify the problematic entries.
SELECT <column_name>,
patindex('%[^ !-~]%' COLLATE Latin1_General_BIN, <column_name>) as [Position],
substring(<column_name>,patindex('%[^ !-~]%' COLLATE Latin1_General_BIN,<column_name>),1) as [InvalidCharacter],
ascii(substring(<column_name>,patindex('%[^ !-~]%' COLLATE Latin1_General_BIN,<column_name>),1)) as [ASCIICode]
from <Database_Name>.[dbo].main
where patindex('%[^ !-~]%' COLLATE Latin1_General_BIN,<column_name>) > 0 ;
Note: Commonly the problematic entry is within the probillnumber column
3. Using the search results record the problematic entry and form a query similar to below.
SELECT * FROM [Database_Name].[dbo].[Main] WHERE <column_name> = '<Field Entry>';
4. Using the query record the In_DocID and modify the invalid entries using a Update statement.
Update [Database_Name].[dbo].[Main] set <Column_Name> = '<Correct Data>' WHERE in_docid = 'synxxxx';
5. Run the query from Step 2 and verify no rows are returned. Users will continue to see the error prompt when accessing Workflow until this occurs.