Introduction:
Synergize applications that uses Registered application from server throws similar error's as shown below.
Error Message:
The content type text/html of the response message message does not march the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSuported method is implemented properly. The first ### bytes of the response were:
'<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
------
</HTML>
Possible cause:
DNS could not resolve the server name while application is trying to establishing connection with Synergize server
Fix:
-Flush DNS using 'ipconfig /flushdns' command from Command Prompt on end user machine.
Additional steps(optional):
-On the client machine, clear the internet cache and make sure the server name is resolving properly.
-Close and relaunch the application, then test.
-Add a server name and IP entry in hosts file using this article: https://support.microdea.com/hc/en-us/articles/203835624-User-can-access-Synergize-Web-Explorer-by-IP-address-and-not-URL
If you have any further questions, please email your questions to support@microdea.com or call support at 905 881 6071 x 290